e107 CMS

e107V2 neu aufsetzen und installieren

Sunday 27 August 2017 - 08:50:00
e107v2_forum_im_frontend.jpg

Hallo liebe Leser und Freunde des Feedbacks! Wie das manchmal so ist, muss man die eine oder die andere CMS-Installation via FTP löschen. Daran kann ein Virus schuld sein oder etwas anderes oder man möchte eine saubere Installation haben. So ging es mir die letzten Tage und ich musste dieses CMS e107v2 ganz vom FTP-Account löschen.

Mein Webhoster hatte für mich ein FTP-Backup der ganzen Domain Wpzweinull.ch und ich hatte alle Datenbanken natürlich nicht gelöscht. Es ist sehr mühsam, neu anzufangen, wo man doch schon so viele Projekte zu betreuen hat.


So habe ich dieses CMS wieder neu installiert und aufgesetzt. Die Beta 1 von e107 bekommt ihr auf der offiziellen Webseite von e107 und danach lädt man alle Verzeichnisse sowie Dateien auf den Webspace hoch. Das kann man mit dem nützlichen Tool Filezilla machen. Das geht immer sehr gut. Dann navigiert man zu der Domain, wo installiert werden soll und wird den Installer vorfinden.

Es ist die Datei install.php, die nach der Installation wieder gelöscht werden muss. So geht man alle Schritte der Installation durch, was bei mir gut geklappt hatte und anschliessend kann man sich im Backend von e107 einloggen. Es wird alles auf Englisch sein, da es noch keine deutsche Sprache für die Version gibt. Ich weiss nicht wie ihr, aber ich komme damit ganz gut zurecht, musste aber im Backend eine Menge ausprobieren und testen, bevor ich so manche Optionen verstanden habe. Das dauert mehrere Tage, wenn nicht ein paar Wochen.

Mit jedem Mal wird man immer besser und kann im Backend auch einiges anstellen. Bekanntlich gibt es bei e107v2 die News, das Forum, man kann die FAQs realisieren und natürlich sind auch statische Seite möglich, die man im Backend erstellen kann. Allerdings war es schwer für mich, nach dem erstellen einer statischen Seite die URL der Seite herauszufinden, weil man die URL braucht, um es in den SiteLinks zu verlinken. Sitelinks sind auch die Links, die im Frontend in der Navigation angezeigt werden. Man kann auch weitere SiteLinks erstellen, braucht aber die URL einer Seite, um sie einzutragen. Vielleicht gibt es ja auch eine andere Möglichkeit, die ich noch nicht kenne. Bei mir war es eben so.

Ich konnte dieses Blog komplett wiederherstellen, da ich die e107_config.php meiner alten Installation hatte. Darin sind die Datenbank-Daten eingetragen. Man wird bei der Installation dieser Datei CHMOD-Rechte 777 setzen müssen, aber nach der Installation geht es wieder zurück zu 644. Das sollte man beachten. Noch hatte ich anfangs keine Bilder gesehen, weil sie nicht in der Datenbank gespeichert werden. Ich musste dann das Verzeichnis e107_media aus der alten Installation hochladen und danach waren die Bilder im Frontend und dem Backend wieder da, wo sie sein sollen. Ich habe ja schon mehrere CMS so neu aufsetzen müssen und wusste ungefähr, dass wenn die Bilder nicht zu sehen sind, kann es nur am FTP liegen, sodass man die Bilder-Verzeichnisse hochladen müsste.

Daran sollte man auch denken. Jetzt habe ich mein Blog wieder zurück und kann mich hier dem Beposten des Blogs und des internen Forums widmen.

Musstet ihr schon mal ein CMS oder e107 neu aufsetzen?

Hattet ihr Probleme damit?

Freue mich auf euer Feedback.

by Alexander Liebrecht




News Categories